App Permissions

Since 5.0, I've been less than satisfied with the "updates" as most of them do not seem like improvements in any way and more like I'm being imposed upon. One of those things was being forced to have (yet another) button taking up screen real estate that forces me to look at an ad--and yes, staring at a button that basically says 'free energon and mission energy, if you press me" is an ad. It took me a while to figure out why my game kept crashing EVERY single time I pressed that button. I don't really care about the ad, now I just press it to see if the problem has been fixed. It still hasn't.

But now I know why. When I looked at the Apps on my LG Stylo 2, specifically on this game, I found out that the Permissions button was greyed out and I was unable to change ANY of the settings. And its only for this game. Every other app I can change on my phone as far as Permissions go, but after this last update, I can't do that for this game anymore. And, as I found out, the Permissions part is what lets me view stuff like ads, video clips, etc., in this game. And its currently greyed out with the button set to deny watching any videos or ads or whatever sponsored in the game.

So, nice one, Kabam. Tempt me with ads for in game 'freebies' and then lock my permissions for the game so I couldn't watch them even if I wanted to.

Now, a mod or two (or all of them) may think this belongs elsewhere and may advise me to file a report, but I put this here for a reason. #1: Kabam has never responded to any report I've ever filed. Ever. And like the other bugs and problems I've reported in the past, I have no confidence in them to resolve it, so I have no intention of filing a report. #2: I put this under "General Discussion" because my intention here is not to report a problem (see #1 if unsure why) but to have a (general) discussion with other players and see if anyone else is having similar issues since the update.
Tagged:

Comments

  • KillMasterCKillMasterC Posts: 2,096
    Although I succeeded in watching a couple of ads at home WIFI, most of the time ads don't work. And they stopped working altogether since yesterday.
    But no crash on click the ad button. The game did crash once since 5.0 for me. But overall it's been stable since 4.1: no crash, no freeze, less loading time, etc.
  • ManthroManthro Posts: 2,423
    So... I just want to understand a couple of things. Does your app setting for the game look like this:

    sjqhzkai4yq3.png

    Sure, it's greyed out but it also says "no permissions requested". I don't have any trouble viewing the ads in the game with it set like this, and I don't think it has anything to do with you not being able to view ads. Of course, I could be wrong. Maybe you had permissions locked down before the update and now they are inaccessible.

    However, I recall bringing up app permissions as a possible cause for crashes in a previous version, and I am certain someone responded as the button always looking like that in two previous versions.

    This brings me to the next part... You've gone on several tirades about the optional ad buttons already... Hey that's cool, that's your opinion. Yet, now you're complaining about a function you apparently don't even want to use in The first place....
  • Hey Halloweendm!

    While we all appreciate a good argument now and then, that doesn't mean this post doesn't still belong in Bugs and Known Issues. As such, I've moved it for you!

    Now that we've taken care of the housekeeping, let's dig a bit more into the issue you're running into. You stated you're on the LG Stylo 2, but what OS version are you on currently? Additionally, have you tried this both on your cellular network and on WiFi? If you're using this as an active phone, what cellular provider are you using? And last, but not least, what is the specific model # of your device (as found in the settings).

    Once we get this info, we can take a deeper look into what may be going on here. Thanks!
  • Manthro,
    Yeah, my screen looks like that. Right below that on the "Open By Default" it reads "No defaults set" but the options for me are greyed out, so I can't even set any defaults. The one default listed for the game is "Don't open supported links". I'm thinking this may have something to do with the link to the ad not being able to be opened. I'm not sure about the permissions. I don't remember any being asked for when I downloaded the game.

    I didn't realize I was tirading. As for not wanting it, that hasn't changed either. I'm just on here asking to see if I can figure out, or find someone who knows why its not working. Personally don't care, but it doesn't work for my son on his phone either and I've had a couple people in my alliance asking about the ads and the new features like the ghost bots in the roster.

    Pepper,
    Its running Android 7.0.
    Yes, I've tried on both phone network and wifi, results are the same.
    Provider is Boost Mobile.
    Model # is LGLS775


Sign In or Register to comment.