Full Mettle Level 3 Mastery Not Working

TsunamiTsunami Posts: 17
edited November 2018 in Bugs and Known Issues
I purchased the cores on sale to max the full mettle mastery. This should be providing a 10% armor buff down to 85% hp. The buff drops off at 90% (which is level 2). I am disappointed since I spent energon to buy the cores for the mastery and it is clearly not working.

I submitted a ticket already to support, but could you please help explain this to the developers and get it fixed, please @Kabam Miike . I also restarted the game several times and also did a clean reinstall and it is still not working.

It is not working in any game mode. I tried alliance mission, raid, story, and arena. I play on an iPad Pro 2.

Thanks for any help you can provide.
9iypxt40ajao.png
pmxzme3rwztbe.png
x8qb2z65bthe.png
wj3gz4fc4kt6.png
s7ue4r6ckbgw.png
hl87pnnn5a8a.png

Comments

  • TsunamiTsunami Posts: 17
    edited November 2018

    So I spend in-game currency to get a mastery that is not working and I don’t have an option to get it back because I did not get what I paid for? How does that make sense? How about I get my energon or mastery cores back and then I can use them how I wish and then once you get it working I can put them back into full mettle if I choose?

    @Kabam Miike @Kabam Vydious @Kabam Rimehaven @Kabam Custos @Kabam Tenebrous

    9yosv56ia7y9.jpeg

  • This is not new. I've brought this up months ago and no one so much as even acknowledged the problem.
Sign In or Register to comment.