Kabam are you actually going to fix the freezing and lag? Or do you just not care anymore?

Im beating a dead horse here. Its been damn near 2 years and the lag and freezing has gotten WORSE. My game freezes LITERALLY every fight. When the game freezes i pause it but as soon as the game unfreezes and i hit resume, my bot is eating a 5 hit combo.

FIX THE LAG AND THE FREEZING NOW. We tired of hearing the same crap "oh we're working on it" NO YOU ARE NOT. If you guys truly are, GIVE US UPDATES ON DEVELOPMENT. Tell us how much progress you're making towards fixing the bugs. Stop leaving us in the dark.

Comments

  • Yes me too .. sometimes its very annoying.. and on loading screen it gives an error "an error has occured" then we have to start the game again. And again same thing happens
  • ManthroManthro Posts: 2,336
    edited December 2018
    Im beating a dead horse here. Its been damn near 2 years and the lag and freezing has gotten WORSE. My game freezes LITERALLY every fight. When the game freezes i pause it but as soon as the game unfreezes and i hit resume, my bot is eating a 5 hit combo.

    FIX THE LAG AND THE FREEZING NOW. We tired of hearing the same crap "oh we're working on it" NO YOU ARE NOT. If you guys truly are, GIVE US UPDATES ON DEVELOPMENT. Tell us how much progress you're making towards fixing the bugs. Stop leaving us in the dark.

    I'm just curious... In those two years have you upgraded your device?

    I'm finding players with these complaints are running ancient devices even by 2yr old standard.

    As in, their phones were already two years old when the game was released and they still haven't upgraded, making their device now 4yrs old.

    No modern game is going to run well on a 4yr old device
  • Darm0kDarm0k Posts: 1,418
    I wonder if it’s a matter of ability rather than them not doing anything. The change log for 7.0.1 said it fixes the whiff issue, but that only seems to have gotten worse for me.
  • Manthro wrote: »
    Im beating a dead horse here. Its been damn near 2 years and the lag and freezing has gotten WORSE. My game freezes LITERALLY every fight. When the game freezes i pause it but as soon as the game unfreezes and i hit resume, my bot is eating a 5 hit combo.

    FIX THE LAG AND THE FREEZING NOW. We tired of hearing the same crap "oh we're working on it" NO YOU ARE NOT. If you guys truly are, GIVE US UPDATES ON DEVELOPMENT. Tell us how much progress you're making towards fixing the bugs. Stop leaving us in the dark.

    I'm just curious... In those two years have you upgraded your device?

    I'm finding players with these complaints are running ancient devices even by 2yr old standard.

    As in, their phones were already two years old when the game was released and they still haven't upgraded, making their device now 4yrs old.

    No modern game is going to run well on a 4yr old device

    im using a Samsung galaxy J7 2016 my phone isn't that old and can run other games with no lag or crashing. Forged to fight is just optimized very poorly on ALL platforms. I hear people that play this game on the Iphone 10 are having the same issues.
  • BlackRazakBlackRazak Posts: 1,791
    Manthro wrote: »
    Im beating a dead horse here. Its been damn near 2 years and the lag and freezing has gotten WORSE. My game freezes LITERALLY every fight. When the game freezes i pause it but as soon as the game unfreezes and i hit resume, my bot is eating a 5 hit combo.

    FIX THE LAG AND THE FREEZING NOW. We tired of hearing the same crap "oh we're working on it" NO YOU ARE NOT. If you guys truly are, GIVE US UPDATES ON DEVELOPMENT. Tell us how much progress you're making towards fixing the bugs. Stop leaving us in the dark.

    I'm just curious... In those two years have you upgraded your device?

    I'm finding players with these complaints are running ancient devices even by 2yr old standard.

    As in, their phones were already two years old when the game was released and they still haven't upgraded, making their device now 4yrs old.

    No modern game is going to run well on a 4yr old device

    im using a Samsung galaxy J7 2016 my phone isn't that old and can run other games with no lag or crashing. Forged to fight is just optimized very poorly on ALL platforms. I hear people that play this game on the Iphone 10 are having the same issues.

    I'm also beating a dead horse, constantly updating a REQUIREMENTS thread, which only ever gets views occasionally and the ONE mod response.

    But I've stated THERE, that age of phones is IRRELEVANT, it's the System on Chips that count.
    The J7 maybe up to spec for everyday tasks, but it runs an SD617...
    Which gained traction in the Motorola Droid Maxx 2/X Play in 2015.

    All SD6xx series phones are/will be terrible for this game.

    SD615, 617, 625, 626, 660 all exhibit multiple errors and FCs.
  • Im beating a dead horse here. Its been damn near 2 years and the lag and freezing has gotten WORSE. My game freezes LITERALLY every fight. When the game freezes i pause it but as soon as the game unfreezes and i hit resume, my bot is eating a 5 hit combo.

    FIX THE LAG AND THE FREEZING NOW. We tired of hearing the same crap "oh we're working on it" NO YOU ARE NOT. If you guys truly are, GIVE US UPDATES ON DEVELOPMENT. Tell us how much progress you're making towards fixing the bugs. Stop leaving us in the dark.

    ...but have you submitted a ticket to the Support Team yet.
    -Probably the mods right now....
  • M00NM00N Posts: 9
    There was an update that allowed me to play without lag and freezes, very fluently, a few days later came an update(11th November, if I am not mistaken), and the game went back on crashing, freezing and lagging even harder. SO why did this happen?
  • DrShotgunDrShotgun Posts: 1,446
    I'm getting this freezing bug on a MotoZ2 force...new phone. It freezes and unfreezes and I'm getting my a$$ handed to me
  • BlackRazakBlackRazak Posts: 1,791
    DrShotgun wrote: »
    I'm getting this freezing bug on a MotoZ2 force...new phone. It freezes and unfreezes and I'm getting my a$$ handed to me

    Same.
    Now UNPLAYABLE on a Z2P but not that horrid on Z2F.
    Have you tried a gamebooster mate, or playing in battery saver mode?
  • We're always working on trying to better optimize the game performance on different devices. However, this can take time and often longer than what may be expected. We can assure you that we are. Posting here saying otherwise doesn't change that fact. We understand being frustrated over this and wanting to vent your anger, but we do ask for your patience in this. There are many different types of devices out there and it takes time to ensure the game and them interact properly.
This discussion has been closed.