Home Bugs and Known Issues

Act 4 Glitch, Can't get 100 percent

3z0xt7uneyqk.png
Got 100 percent on everything, but the overall only shows 97 and won't give me the exploration rewards. Anyone else run into this?
(Android 7.1.1, Moto E4, USA)
Tagged:

Comments

  • Darm0kDarm0k Posts: 2,397
    I’m pretty sure it’s because you haven’t completed and explored chapter 2 yet. Or 3. And no, they’re not out yet.
  • KillMasterCKillMasterC Posts: 3,079
    97% still looks weird mathematically. Should be something like 33% (3 chapters), 25% (4 chapters) or 100% ("for now")
  • ManthroManthro Posts: 2,752
    You will only get exploration rewards after all the chapters are released and explored.

    That's why it doesn't read 100%
  • Why don't you all think twice before posting anything on the forums? Don't you see chapter 2 locked and yet to be released??
  • DonApisDonApis Posts: 544
    Why don't you all think twice before posting anything on the forums? Don't you see chapter 2 locked and yet to be released??

    I couldn't agree more on this
  • Why don't you all think twice before posting anything on the forums? Don't you see chapter 2 locked and yet to be released??

    If that was the issue, one would expect it to be 50 percent or so, not 97, leading one to believe that there is a glitch and chapter two has its own exploration meter. That may yet turn out to be the case, though. This scenario coupled with the fact that reward glitching has been extensive lately compelled me to ask the forum community. However, the forums seem to be a lousy place to go for such things as they are replete with condescending know-it-alls.
Sign In or Register to comment.